BETA

1st March 2018

West Bengal Issue observed for 'Incoming Calls' in West Bengal Region

Identified at [01/03/18 08:31 PM] with 'Major Outage'

We are investigating this issue at priority.

Issue has been resolved at [01/03/18 10:39 PM]