BETA

28th March 2017

Karnataka Issue observed for 'Incoming Calls' in Karnataka Region

Identified at [28/03/17 06:27 AM] with 'Partial Outage'

Issue has been resolved at [28/03/17 06:28 AM]