BETA

28th March 2017

Mumbai Issue observed for 'Incoming Calls' in Mumbai Region

Identified at [28/03/17 06:26 AM] with 'Major Outage'

Issue has been resolved at [28/03/17 06:34 AM]