BETA

1st March 2018

West Bengal Issue observed for 'Incoming Calls' in West Bengal Region

Identified at [01/03/18 02:34 PM] with 'Major Outage'

Issue has been resolved at [01/03/18 02:35 PM]