BETA

1st March 2018

Outgoing SMS Issue observed for Outgoing SMS across India

Identified at [01/03/18 12:07 PM] with 'Partial Outage'

Issue has been resolved at [01/03/18 12:09 PM]