BETA

28th February 2018

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [28/02/18 05:10 PM] with 'Partial Outage'

Issue has been resolved at [28/02/18 05:14 PM]