BETA

28th February 2018

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [28/02/18 04:56 PM] with 'Major Outage'

Issue has been resolved at [28/02/18 04:58 PM]