BETA

28th February 2018

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [28/02/18 04:01 PM] with 'Partial Outage'

We are investigating this issue at priority.

Issue has been resolved at [28/02/18 04:10 PM]