BETA

27th February 2018

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [27/02/18 02:44 PM] with 'Major Outage'

Issue has been resolved at [27/02/18 02:45 PM]