BETA

27th February 2018

Delhi Issue observed for 'Outgoing Calls' in Delhi Region

Identified at [27/02/18 02:35 PM] with 'Major Outage'

Issue has been resolved at [27/02/18 02:36 PM]