BETA

26th February 2018

Delhi Issue observed for 'Outgoing Calls' in Delhi Region

Identified at [26/02/18 12:55 PM] with 'Major Outage'

Issue has been resolved at [26/02/18 12:56 PM]