BETA

25th February 2018

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [25/02/18 10:12 PM] with 'Major Outage'

Issue has been resolved at [25/02/18 10:13 PM]