BETA

25th February 2018

West Bengal Issue observed for 'Incoming Calls' in West Bengal Region

Identified at [25/02/18 05:00 PM] with 'Major Outage'

Issue has been resolved at [25/02/18 05:06 PM]