BETA

28th March 2017

Gujarat Issue observed for 'Incoming Calls' in Gujarat Region

Identified at [28/03/17 12:45 AM] with 'Partial Outage'

Issue has been resolved at [28/03/17 12:51 AM]