BETA

25th February 2018

Chennai Issue observed for 'Outgoing Calls' in Chennai Region

Identified at [25/02/18 10:07 AM] with 'Major Outage'

Issue has been resolved at [25/02/18 10:08 AM]