BETA

25th February 2018

Gujarat Issue observed for 'Outgoing Calls' in Gujarat Region

Identified at [25/02/18 06:42 AM] with 'Major Outage'

Issue has been resolved at [25/02/18 06:43 AM]