BETA

25th February 2018

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [25/02/18 06:40 AM] with 'Major Outage'

Issue has been resolved at [25/02/18 06:42 AM]