BETA

25th February 2018

Delhi Issue observed for 'Outgoing Calls' in Delhi Region

Identified at [25/02/18 05:43 AM] with 'Major Outage'

Issue has been resolved at [25/02/18 05:44 AM]