BETA

26th March 2017

Outgoing SMS Issue observed for Outgoing SMS across India

Identified at [26/03/17 10:19 PM] with 'Partial Outage'

Issue has been resolved at [26/03/17 10:21 PM]