BETA

24th February 2018

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [24/02/18 11:07 AM] with 'Partial Outage'

Issue has been resolved at [24/02/18 11:09 AM]