BETA

24th February 2018

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [24/02/18 04:48 AM] with 'Major Outage'

Issue has been resolved at [24/02/18 04:50 AM]