BETA

26th March 2017

Chennai Issue observed for 'Incoming Calls' in Chennai Region

Identified at [26/03/17 02:10 PM] with 'Partial Outage'

We are investigating this issue at priority.

Issue has been resolved at [26/03/17 10:48 PM]