BETA

24th February 2018

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [24/02/18 04:30 AM] with 'Partial Outage'

We are investigating this issue at priority.

Issue has been resolved at [24/02/18 04:32 AM]