BETA

26th March 2017

Karnataka Issue observed for 'Incoming Calls' in Karnataka Region

Identified at [26/03/17 07:36 AM] with 'Partial Outage'

We are investigating this issue at priority.

Issue has been resolved at [26/03/17 08:15 AM]