BETA

24th February 2018

Gujarat Issue observed for 'Outgoing Calls' in Gujarat Region

Identified at [24/02/18 04:06 AM] with 'Major Outage'

Issue has been resolved at [24/02/18 04:07 AM]