BETA

24th February 2018

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [24/02/18 04:02 AM] with 'Major Outage'

Issue has been resolved at [24/02/18 04:04 AM]