BETA

26th March 2017

Gujarat Issue observed for 'Incoming Calls' in Gujarat Region

Identified at [26/03/17 07:35 AM] with 'Partial Outage'

We are investigating this issue at priority.

Issue has been resolved at [26/03/17 08:24 AM]