BETA

24th February 2018

Andhra Pradesh Issue observed for 'Outgoing Calls' in Andhra Pradesh Region

Identified at [24/02/18 03:48 AM] with 'Major Outage'

Issue has been resolved at [24/02/18 03:49 AM]