BETA

24th February 2018

Delhi Issue observed for 'Outgoing Calls' in Delhi Region

Identified at [24/02/18 03:21 AM] with 'Major Outage'

Issue has been resolved at [24/02/18 03:24 AM]