BETA

24th February 2018

Chennai Issue observed for 'Outgoing Calls' in Chennai Region

Identified at [24/02/18 02:56 AM] with 'Major Outage'

Issue has been resolved at [24/02/18 02:57 AM]