BETA

23rd February 2018

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [23/02/18 08:25 PM] with 'Partial Outage'

Issue has been resolved at [23/02/18 08:27 PM]