BETA

23rd February 2018

Chennai Issue observed for 'Outgoing Calls' in Chennai Region

Identified at [23/02/18 04:56 PM] with 'Major Outage'

Issue has been resolved at [23/02/18 04:57 PM]