BETA

23rd February 2018

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [23/02/18 12:55 PM] with 'Major Outage'

Issue has been resolved at [23/02/18 12:56 PM]