BETA

26th March 2017

Karnataka Issue observed for 'Incoming Calls' in Karnataka Region

Identified at [26/03/17 07:00 AM] with 'Major Outage'

Issue has been resolved at [26/03/17 07:01 AM]