BETA

23rd February 2018

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [23/02/18 11:24 AM] with 'Partial Outage'

Issue has been resolved at [23/02/18 11:25 AM]