BETA

23rd February 2018

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [23/02/18 11:21 AM] with 'Major Outage'

We are investigating this issue at priority.

Issue has been resolved at [23/02/18 11:27 AM]