BETA

26th March 2017

Gujarat Issue observed for 'Incoming Calls' in Gujarat Region

Identified at [26/03/17 06:48 AM] with 'Partial Outage'

Issue has been resolved at [26/03/17 06:56 AM]