BETA

26th March 2017

Delhi Issue observed for 'Incoming Calls' in Delhi Region

Identified at [26/03/17 06:23 AM] with 'Major Outage'

Issue has been resolved at [26/03/17 06:24 AM]