BETA

23rd February 2018

Delhi Issue observed for 'Outgoing Calls' in Delhi Region

Identified at [23/02/18 02:05 AM] with 'Major Outage'

Issue has been resolved at [23/02/18 02:06 AM]