BETA

22nd February 2018

Gujarat Issue observed for 'Outgoing Calls' in Gujarat Region

Identified at [22/02/18 02:20 PM] with 'Major Outage'

Issue has been resolved at [22/02/18 02:21 PM]