BETA

22nd February 2018

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [22/02/18 01:58 PM] with 'Major Outage'

Issue has been resolved at [22/02/18 01:59 PM]