BETA

22nd February 2018

Andhra Pradesh Issue observed for 'Outgoing Calls' in Andhra Pradesh Region

Identified at [22/02/18 01:38 PM] with 'Major Outage'

Issue has been resolved at [22/02/18 01:39 PM]