BETA

22nd February 2018

Chennai Issue observed for 'Outgoing Calls' in Chennai Region

Identified at [22/02/18 01:09 PM] with 'Major Outage'

Issue has been resolved at [22/02/18 01:10 PM]