BETA

22nd February 2018

Outgoing SMS Issue observed for Outgoing SMS across India

Identified at [22/02/18 09:11 AM] with 'Major Outage'

Issue has been resolved at [22/02/18 09:21 AM]