BETA

21st February 2018

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [21/02/18 08:26 PM] with 'Partial Outage'

Issue has been resolved at [21/02/18 08:27 PM]