BETA

21st February 2018

Chennai Issue observed for 'Outgoing Calls' in Chennai Region

Identified at [21/02/18 06:18 PM] with 'Major Outage'

Issue has been resolved at [21/02/18 06:19 PM]