BETA

26th March 2017

West Bengal Issue observed for 'Incoming Calls' in West Bengal Region

Identified at [26/03/17 05:44 AM] with 'Partial Outage'

We are investigating this issue at priority.

Issue has been resolved at [26/03/17 08:19 AM]