BETA

21st February 2018

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [21/02/18 08:39 AM] with 'Major Outage'

Issue has been resolved at [21/02/18 08:40 AM]