BETA

20th February 2018

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [20/02/18 09:51 PM] with 'Partial Outage'

Issue has been resolved at [20/02/18 09:52 PM]