BETA

20th February 2018

Chennai Issue observed for 'Outgoing Calls' in Chennai Region

Identified at [20/02/18 07:35 PM] with 'Major Outage'

Issue has been resolved at [20/02/18 07:36 PM]